What's new

Tutorial Xenon RGH1.2 Freeboot Tutorial

  • Thread starter Metal
  • Start date
  • Views 58,830

Have you had success with RGH1.2 on your Xenon?

  • Yes

    Votes: 37 64.9%
  • No

    Votes: 20 35.1%

  • Total voters
    57
L

larveyhong

Newbie
Messages
4
Reaction score
0
I just got this to work on Xenon with ACEV3 and 22k resistor on PLL.
This works very nice (borat voice) and instaboots everytime.

edit: Taiwan CPU+GPU
 
Last edited:
O

Octal450

Enthusiast
Messages
23
Reaction score
10
Well GPU went out on mine.. changed for same model but Korean and the starts are slower. It still launches but worse. Same wiring and ACE but the set-top box is acting worse.

I'm investigating... sadly the old GPU is dead or I'd put it back and see. L larveyhong GPU is also on its way out, so weird... 2 failing mashines launch instantly, but repairing the GPU makes it worse??

Especially since Xenon with 80nm ELPIS GPU never launches RGH on anybody...

I'm wondering if the GPU affects RGH for Xenon.

Kind Regards,
Josh
 
D

duckmansweb

Newbie
Messages
8
Reaction score
1
Hi all, just confirming this is correct for my ACE V3 - as mine looks slightly different to the one pictured

dvRNiNn.jpg
 
B

BluesMan67

Enthusiast
Messages
369
Reaction score
44
Hi all, just confirming this is correct for my ACE V3 - as mine looks slightly different to the one pictured

dvRNiNn.jpg
Yes,remove/De-solder that SS14 Diode if your RGH'ing a "360 Phat" console and the 1.8v pad next to the SS14 diode is only used for the 360 "Phat" RGH installs.
If your RGH'ing a 360 Slim,then leave the diode alone and don't solder any wire to the 1.8v pad,as you don't need to.
 
D

duckmansweb

Newbie
Messages
8
Reaction score
1
About to start an Xenon that’s been used twice and was updated to 8955.
Ive had success getting into Xell so far - so this is a good start (see vid) Video
 
Last edited:
R

rstblz

Newbie
Messages
3
Reaction score
0
This xenon very interesting to RGH, thanks for the tutorial.

Since I'm affraid breaking my 2005 launch Xenon so just bought cheap xenon from OLX (Local online used marketplace here).

Don't have luck finding Ace V3 so use Matrix V3 with oscillator instead.

Couldn't manage get Xell, so experimenting a bit, replaced 48Mhz oscillator to 100Mhz, enabled caps on matrix, wrap PLL & RST cables with black tape for shielding, not using resistor for PLL, All wiring (PLL, RST, POST) use via on top of motherboard to get shortest length.

boom.. boot Xell and Freeboot, but very sporadic, sometime below 1 minutes, sometimes need over 2 minutes to boot.

well, guess that's the best I can get, next after I get Ace Chip will trying again, maybe I can get better boot times.
 
A

amxcs

Newbie
Messages
17
Reaction score
2
Link is dead :frown:

I create xebuild with another version of autogg 17559, but now no freeboot or xell
Before that boot to xell for 10-20 seconds.
Does it need to change timings or I messed something with xebuild?
The RGH was fine, the problem was in the unsoldered GPU chip...
After overheating, I tried and booted into a freeboot.
But with this unsoldered GPU chip, the console is for the bucket. :frown:
 
O

Octal450

Enthusiast
Messages
23
Reaction score
10
Couldn't manage get Xell, so experimenting a bit, replaced 48Mhz oscillator to 100Mhz
Did you compile new timings? Otherwise such a frequency change is not possible. The timing increments once (or twice if you want to count on the rising and falling edge) per clock cycle. If you change the working frequency, you need to recompile the timings with the values all adjusted in the glitch counters, and the dividers for the slowdown delay.

Also - resistor is not used for matrix, its on board. The ACE doesn't have it as it wasn't designed for PLL slowdown.

So I'd like to see a demonstration of what you did and/or providing exactly what timings you used.

Kind Regards,
Josh
 
N

Newsk

Contributor
Messages
2,524
Reaction score
332
O Octal450 Would love to see a demonstration on how exactly to adjust/make 15432s timing files. Probably not that difficult but wouldn't know where to begin.. Also u mentioned learning all the tricks to getting these xenons to boot more reliably what all did you learn? Wire routes/lengths etc. I only find 2 out of 10 boot up. If you have some time would appreciate if u could pm me for some more info . Thanks
 
O

Octal450

Enthusiast
Messages
23
Reaction score
10
Would love to see a demonstration on how exactly to adjust/make 15432s timing files.
I'll probably make a tutorial at some point to my YouTube. You need Xilinx ISE 14.1 (I use System Edition) and Matlab (trial is ok). I'm still working on a reliable RGH1.2 source code (his dev folder source has alot of experiments/broken things, so it needs to be fixed before it can be used) - some of the Xenon problems might be that the X360ACE version of RGH1.2 is already picky - even the Jaspers don't like it... Once i get the most stable source for the coolrunners worked out, I'll look at the ace version. GliGli or Tiros wrote something about how there may be a time to release PLL bypass where the CPU doesn't hang and I'll see if I can find it.

Probably not that difficult but wouldn't know where to begin.. Also u mentioned learning all the tricks to getting these xenons to boot more reliably what all did you learn?
It was just some advice about the timing files to use, and then I tuned by visual debug. Tuning wire routing won't really help here as the problem is in the CPU itself.

Kind Regards,
Josh
 
O

Octal450

Enthusiast
Messages
23
Reaction score
10
N Newsk
I have working ACE RGH1.2 code now, instaboots my Falcon/Jasper. actually redesigned it a bit, next step... Xenons...
Will update when progress.

Kind Regards,
Josh
 
A

anti77

Newbie
Messages
1
Reaction score
0
I create xebuild with another version of autogg 17559, but now no freeboot or xell
Before that boot to xell for 10-20 seconds.
Does it need to change timings or I messed something with xebuild?
Same here, after uploading a 17559 flash generated with CPUKEY with autogg no more XELL or freeboot. I'm using LPT and it takes 4 hours to load a nandflash with nandpro...

Before it took some time like 10-20 minutes, but it did went into XELL from the Xenon.ecc. Now it's only rapid green flashing (if no DVD connected) or solid green if DVD connected, led on ACEV3 blinks as pe dynamic XENON.

I did changed thermal paste in between, maybe I've unsoldered GPU/CPU?
 
O

Octal450

Enthusiast
Messages
23
Reaction score
10
You did not undersolder him. That is impossible. Unless you did with BGA rework machine lol.
Kind Regards,
Josh
 
O

Octal450

Enthusiast
Messages
23
Reaction score
10
I now have my custom VHDL code booting my Xenon. Will work on refining it and see if I get anywhere.

Kind Regards,
Josh
 
O

Octal450

Enthusiast
Messages
23
Reaction score
10
Works on a Rev-C with my new code too.

Need to test more than I'll upload some files for you people to try, X360ACE and Matrix/Coolrunner versions both working.

Kind Regards,
Josh
 
Top Bottom