What's new
  • Howdy, Guest!

    We have issued a forced password reset on all user accounts, meaning you will not be able to login until this process is complete. Instructions will be displayed when you login with your previous credentials, however if for any reason you do not have access to your associated email address, you will need to contact us at [email protected].

    For more information, please read this Important Announcement

    Thank you for being awesome!

Solved Why jtag not boot?

  • Thread starter kingbear
  • Start date
  • Views 1,011
K

kingbear

Enthusiast
Messages
65
Reaction score
11
Points
55
Sin$
0
Alright im gonna try be very specific with what im doing.

The first thing I used was

I have the back up the nand. I checked they do have a bad block. Not sure if its a big deal

1) I erased. the nand on the jtag via lpt.
nandpro lpt: -e16 0 400

2) I wrote xell
nandpro lpt: -w16 Xell.bin

Got the CPU Key

3) Read the KV out of the nand.

nandpro nand.bin: -r16 rawkv.bin 1 1

4) Downloaded XBR for my xbox and injected the rawkv.bin

nandpro xbr.bin: -w16 rawkv.bin 1 1

5) Write the xbr.bin to Xbox

nandpro lpt: -w16 xbr.bin

6) When complete Unplug LPT from Xbox

7) Unplug the power chord and leave out for 30 secs.

8) Connect powerchord back and turn on.


Anyone tell me if I did the steps correctly. I was detailed as to what i did.

SOLUTION AFTER JTAG WENT DEAD

My jtag went dead and would not turn on after due to bad flash.

This is what i did and started working fine.

You need to erase the nand.

nandpro lpt: -e16 0 400

Obviously this will not work if you can't power your jtag or its dead. You will recieve like a connection or no communication with the computer.

So in order to do this you must disconnect ONLY your power chord connected to your jtag. Leave the lpt cable connected from your computer to the jtag and the video cable connnected.

Now type again nandpro lpt: -e16 0 400 and keep the power chord right next to the power port. As soon as you press enter you must insert the cable.

If done correctly you should start seeing your nand being erased. If you receive errors. You must do again until the erase is clean.

Once you have completely erased the nand. You need to disconnect the power chord again.


WRITE THE XBR TO YOUR JTAG.

Now you need to write the xbr to your jtag.

In order to do this you need to write them in blocks. Otherwise you will get errors.

Step 1: Type: nandpro lpt: -w16 xbr.bin 0 2
Note: 0 is where you would like to start to write from. 2 is the blocks you would like to write. Do them in 2 blocks for now because if you do more you will maybe get errors and have to wait longer.

Step 2: Same as the erase process you need to put cable back in as soon as you press enter. If done correctly it will write 2 blocks. If you recieve an error you need to just keep in mind where the error block.

Example:

nandpro lpt: -w16 xbr.bin 0 2
Writing 0000 - 0001

nandpro lpt: -w16 xbr.bin 2 2
Writing 0002 - 0003

nandpro lpt: -w16 xbr.bin 4 2
Unable to connect or something that shows it can't write.

You need to disconnect the power cable again. If it writes a block and you get an error let's say the next block. You need to start from the block you got the error.

Let' say the error is at 0004.

So you start again

nandpro lpt: -w16 xbr.bin 4 2 (Connect cable as soon as you press enter)
It should write another 2 blocks or 1. Continue to do the same thing until i believe block 2A or something like that.

I increased the block from 2 - 10 because it was not giving me errors anymore.

Right after that I believe the writing can be done with more blocks without getting errors anymore. You just need to write the rest of the xbr.bin onto the jtag.

If you get errors you need to start from the block you got the error.

This is what I did and worked for me.

I did get an error furthur down at 18f. So if you did put 50 or more. And start getting errors disconnect ethernet. Then power. Connect ethernet back and start from error. I wrote 2 blocks again. Errors stopped like after 1A8 i think. Then increase the block write. But maybe for you might different. Just keep doing it until you complete the write
 
B

BHetrick

Enthusiast
Messages
211
Reaction score
15
Points
70
Sin$
7
Remap your bad block and also add your config.bin to XBR.bin, then flash nand.

nandpro nand.bin: -r16 config.bin 3de 2
nandpro xbr.bin: -w16 config.bin 2de 2
 
K

kingbear

Enthusiast
Messages
65
Reaction score
11
Points
55
Sin$
0
If anyone has a bad jtag and does not boot due to bad flash. Try this solution. And write a reply back if it worked for you.

If there is a mod please change the topic to. Jtag does not turn on or something that can help people with the same problem i had without opening the jtag.
 
Top Bottom
Login
Register