What's new

Unsolved trinity RGH matrix install gone wrong

E

EuphoricAlien

Newbie
Messages
3
Reaction score
1
I wanted to rgh my Xbox 360 Slim trinity for cheap. Bought a Matrix Nand flasher (MTX SPI Flasher V1.0) + ACEv5 so i dont have to deal with timing files.

The following Steps worked fine:
1. Sodering the Matrix programmer to the mainboard.
2. Reading Nand in 2 identical Reads without major Errors.
3. Creating and Flashing ECC
After that I sodered the ACEv5 in place. The Console would not boot. Just one Beep sound, fan not spinning.
I reflashed the ECC until eventually the console started with fan spinning. No Picture on HDMI. ACEv5 blinks 3-4 times, Console LED blinks green for a minute then turns to solid red.

Fist thing i want to get working at this point is booting from the original retail Nand. I have made Backups of the fist Reads.
I desodered the 3v3 power of the glitch chip, reanamed the nanddump1 to updflash.bin, selected that one in Jrunner and flashed it.
The Console wont turn on. After multiple trys of flashing the original Nanddump i get one of the two Errors: 1. Just Beep sound + red LED or 2. spinning fan + LED blinking green but turning red after a minute

Besides that I cant read the Nand without getting Error 258 in every Block.

I already desodered the Matrix programmer, cleaned everything up and resodered with new clean wires as good as possible.

I think its really strange to get different console behaviour after flashing the exact same nanddump. Is my Matrix Programmer Broken?
If so, is my fist / backup Read even usable? Did i miss anything flashing back the original nand? Should i invest in a real nandx or jrprogrammer or is my console screwed already at this point :/
 
D

danik2b

Enthusiast
Messages
54
Reaction score
7
looks like your nand is corrupt.
 
E

EuphoricAlien

Newbie
Messages
3
Reaction score
1
Thanks for your advise!
I managed to get the original stock Image to Boot again.

Here is what i did:
1. installed nandpro 3.0
2. erased nand using "nandpro usb: -e16" multiple times
3. I flashed my very fist nanddump back to console "nandpro usb: -w16 imagefile.bin"

In that last step i got "usb_control_msg failed -5" for every block, but i guess that is due to the cheap matrix programmer

In step 2 i got this:
Flash Config: 0x00023010
Block Size: 16KB Block Limits: 0x000000..0x0003FF
File:
Erasing
Error: 202 erasing block 1B4
03FF

Dont know what is up with that block 1B4, got this Error in every try.

Next up i will try the RGH Mod again.
 
E

EuphoricAlien

Newbie
Messages
3
Reaction score
1
I finally got everything working!

First thing i did after getting back to stock nand booting was creating and flashing ECC with Jrunner. But the console wont boot to Xell.

I figured that Jrunner is not flashing correctly (at least with my cheap matrix programmer)
because flashing the Original stock nanddump did not work in many trys but worked fine with nandpro in first try.

So i copied the ECC file created with Jrunner to nandpro folder and flashed it via cli with "nandpro usb: +w16 image_00000000.ecc"
(From nandpro usagefile: +w# Write RAW (with SPARE) file, init SPARE, block numbers, ECC)

The flashing process took a little longer compared to Jrunner but the console started to Xell.

I got the CPU-key, created XeBuild with Jrunner, flashed the new updflash.bin again using nandpro "nandpro usb: -w16 image_00000000.ecc"

With the harddrive attached the console successfully boots to rghed Dashboard :biggrin:

Thank you guys for the support!
 
Top Bottom