What's new

Unsolved *Sigh* First time Demon Install wont boot retail?

  • Thread starter xXBeefyDjXx
  • Start date
  • Views 196
X

xXBeefyDjXx

Long time Sinner
Messages
1,587
Reaction score
452
Hey all,

Makes a change for me to be asking a question, but this is some seriously weird behaviour....

I have a CR Rev C (Clone, sadly) and a legit Demon Slim. I installed the CR first and it booted fine once a RGH2 nand was flashed to the Trinity console I am doing this to.

I've wanted a true Demon setup for ages now (I had a x360pro Dual Nand Kit back in 2012), so finally got a slim chip. It's the real deal!

I triple checked every single solder joint, before introducing power, double checked the Demon worked by using the Demon Toolbox and it does work.

My issue is that I can read and write both nands perfectly fine, and the Demon Nand boots into RGH2 perfectly fine, but if I switch to stock and try to turn it on, it just sits there with the power light on, I inspected the Coolrunner, and it appears that it flashes the green light for a split second after turning on the stock nand, then, nothing. Dormant console.

I read about putting the CR into PRG mode to test and can confirm that when the CR is in PRG mode the retail nand does boot normally, so the Demon is NOT turning off the coolrunner chip. I double checked the EN points and have flashed the CR with the correct timing files for Trinity Demon, no change.

WTF is going on? The only thing I can think, is that the PCB doesn't have the EN patch attached to the correct place, being a clone. So can anyone tell me where EN leads to on a Rev C? Thanksss
 
B

BlueSn00w

RGH/JTAG Seller
Messages
257
Reaction score
40
Last time i checked, you needed to use the demon timing files? Long time since i did a demon, Just check.
 
Ed30BR8.png

Yep, make sure thats ticked.
 
X

xXBeefyDjXx

Long time Sinner
Messages
1,587
Reaction score
452
Last time i checked, you needed to use the demon timing files? Long time since i did a demon, Just check.
 
Ed30BR8.png

Yep, make sure thats ticked.
Already done this, I said in the OP that I used the "Trinity Demon" timing files. I have flashed them multiple times just to be sure. It completes, Power cycled the console, nada. One, insanely fast green flash, nothing unless I turn the chip to PRG mode.

Demon side works perfect, chip isn't turning off. :frown:
 
T

TheWeekendModder

Enthusiast
Messages
284
Reaction score
93
You might double check me with a MM, but I think the EN point on the demon will only have 3.3v power when the demon nand is selected. You can probably get away with wiring from the PWR pad on the Rev C to the EN point on the demon.

Essentially using the EN point as the power source for the glitch chip, thereby only powering it in demon nand mode.
 
X

xXBeefyDjXx

Long time Sinner
Messages
1,587
Reaction score
452
You might double check me with a MM, but I think the EN point on the demon will only have 3.3v power when the demon nand is selected. You can probably get away with wiring from the PWR pad on the Rev C to the EN point on the demon.

Essentially using the EN point as the power source for the glitch chip, thereby only powering it in demon nand mode.
It's a tricky one, Considering how long it took me to find this slim Demon, I really want to do this the way it was intended and avoid any potential brick situations, $130 including shipping and import taxes to the UK :frown:

I think i'll just try getting another "Clone" Coolrunner since a majority don't have the EN point on, but some are pictured with it on, the assumption is they must be using a cheaper chip that doesn't have that pin logic on it, hence why it doesn't work...

The quest continues....
 
Top Bottom