What's new

Discussion should I just downgrade to 1.51?

Status
Not open for further replies.
V

vato

Enthusiast
Messages
125
Reaction score
7
I currently have ixtreme 1.6 firmware and so do all my other friends. According to the community 1.7 will be for the wave 4 games which have been launched in according to the August update.

So my question is, should I just downgrade to 1.51 because it can play any wave, because all 1.6 does is make sure you don't play any corrupt games or play a higher wave.

Thanks in advance
 
P

pimpfuu

Enthusiast
Messages
476
Reaction score
63
vato said:
I currently have ixtreme 1.6 firmware and so do all my other friends. According to the community 1.7 will be for the wave 4 games which have been launched in according to the August update.

So my question is, should I just downgrade to 1.51 because it can play any wave, because all 1.6 does is make sure you don't play any corrupt games or play a higher wave.

Thanks in advance
no, 1.6 can play any games as well, but if they arnt stealth it blocks them for your safety, all you have to do is download and burn activate.iso, and put it in your xbox, and it will turn to one shot boot mode, and will play any 360 game no matter if its stealth or not, but the fact is that it is very risky, and easily known by live that you are play burnt games, and is a much higher risk of getting banned, weather you do it on 1.51 or 1.6.

your best bet is to just be patient and wait for either 1.61 or 1.7 to come out, it should be released within a few weeks i would estimate.
 
E

EclipseModz

VIP
VIP
Retired
Messages
7,688
Reaction score
2,714
1.5 1.51 and 1.6 have the same stealth check. That is why 1.51 was made. So it could accommodate the 3rd wave. Then shortly after that 1.6 was made. Now either they are going to make a update to 1.6 or make a whole new firmware and have 1.7

Just keep 1.6 and play the activate.iso if you need to play a wave 4 game.
 
V

vato

Enthusiast
Messages
125
Reaction score
7
I already know about the activate .iso but then im gonna need to swap the discs every time ... lol
 
T

Twis7eD

Banned
Messages
2,701
Reaction score
575
Yeah, it seems pretty pointless to downgrade to 1.5 because of reasons already stated. Just keep your 1.6 and wait for 1.61 or 1.7 to come out. It should be out pretty soon so downgrading would be pretty pointless.
 
Venomous Fire

Venomous Fire

Retired Admin 4 Life
VIP
Retired
Diamonds Are Forever Mythical Veteran Odysseus' Summit
Messages
8,310
Reaction score
3,277
only hitachi 1.51 can play wave 4 without anything extra
 
H

HOBO POW3R

Enthusiast
Messages
813
Reaction score
788
yah i agree with the twis7ed they will probably have a 1.61 soon which will basicly be like what 1.51 was when wave 3 came
 
P

pimpfuu

Enthusiast
Messages
476
Reaction score
63
HOBO POW3R said:
yah i agree with the twis7ed they will probably have a 1.61 soon which will basicly be like what 1.51 was when wave 3 came
oh yea, i forgot to tell you about this^
 
Status
Not open for further replies.
Top Bottom