What's new
  • Howdy, Guest!

    We have issued a forced password reset on all user accounts, meaning you will not be able to login until this process is complete. Instructions will be displayed when you login with your previous credentials, however if for any reason you do not have access to your associated email address, you will need to contact us at [email protected].

    For more information, please read this Important Announcement

    Thank you for being awesome!

Question Need Help Diagnosing a No Power Issue. (Falcon/RGH1.2)

  • Thread starter Deleted member 1672971
  • Start date
  • Views 251
D

Deleted member 1672971

Newbie
Messages
1
Reaction score
0
Points
10
Sin$
0
Hi, I glitched my console around 10 years ago and it was working fine, no issues, So doubtful it's the RGH. A couple days ago it kinda just died while I was playing. I know it's a long shot, but I was just wondering if anyone has any tips/suggestions on what I should check. If it helps, It died while I was playing so the Power and Player 1 LEDs were still on, but everything else was off. I tried turning it off at the power button but it didn't work so I unplugged it. Then I waited a bit and plugged it back in, and power button didn't work, tried to turn it on using eject, that didn't work. also tried the controller.

I've since opened it up and these are the things I've tried/checked based on what I've read:
USB ports: pins are not bent. Apparently causes the same problem I have, or at least similar.
Power brick (stays orange): I've ruled that one out since the Glitch Chip still get's power. LED turns on when Plugged in. Though I could be wrong.
Capacitors: 2 look like they're bulging at the top, but I can't be sure. It hasn't popped or leaked nor is it obvious enough for me to be confident.
The two MOSFETs, U5B1 and/or U5B2, are hot when plugging it in though. So I'm leaning towards those.

I haven't checked for shorts because I have no clue where to start. So can anyone point me in the direction of which points to check or if anyone has had similar "symptoms", what fixed it? or am I out of luck and the board is fried?
 
bvop

bvop

Enthusiast
Messages
62
Reaction score
5
Points
60
Sin$
7
So when I had this issue, a fuse blew in my xenon and caused a red ring. It's most likely those mosfets though which are causing you a problem.
 
Top Bottom
Login
Register