Xbox 360 MW3 Force Host No Longer Works

Discussion in 'Call of Duty: MW3 Support' started by StenchOfDeth, Jul 14, 2018 with 3 replies and 161 views.

Thread Status:
Not open for further replies.
  1. StenchOfDeth

    StenchOfDeth Enthusiast

    Messages:
    133
    Ratings:
    22
    For the past couple of days, I can no longer force host. Whenever I try, all I get is "Waiting for better host". I haven't changed anything, but Ninja is currently in Free Mode. Still, I can't say that's the cause. It's just the only thing that's changed that I'm aware of. Bummer since I like to host lobbies where everyone can have fun with super jump, unlimited ammo, XP, etc.

    Anyone have a clue?

     
  2. Casp

    Casp Retired Retired

    Messages:
    2,184
    Ratings:
    5,300
    Before anything, since you're running NiNJA (and, presumably, NiNJA Engine) make sure that the "Never Host" option is not selected. NiNJA Engine has a bad habit of selecting options when it's not open.
    In the event that Never Host is not selected, the game will prevent you from being host if your NAT is closed or if you were host during a game and your connection went under so host privileges migrated to another client. If it is happening immediately and before you even host a single match, make sure your NAT is not closed (moderate is finicky, but it still works) and that the required ports are open. If NiNJA's free mode is actually a contributing factor of this issue, my best guess would be the increased traffic on the service, but that's total conjecture.
     
  3. Cakes

    Cakes ~ Administrator

    Messages:
    20,272
    Ratings:
    16,991
    The load on NiNJA's server wouldn't affect his ability to get host in any game.
     
  4. OP
    StenchOfDeth

    StenchOfDeth Enthusiast

    Messages:
    133
    Ratings:
    22
    As it turns out, the Ninja engine.ini file had the "SpoofIP" entry enabled ("Never Host" was already disabled). Now, MW3 has no menu option to set this, so I may have set it in the BO2 menu. Still, I haven't played BO2 for weeks, so I wonder why "SpoofIP" being enabled would cause problems only just recently. In any case, once I disabled "SpoofIP", force host was available again.

    Thank you all for taking the time to reply!
     
Thread Status:
Not open for further replies.