What's new

Discussion Massive frame rate issues on GTA

  • Thread starter handsomepigeonzz
  • Start date
  • Views 185
H

handsomepigeonzz

Enthusiast
Messages
223
Reaction score
12
My specs:
Intel i5 4690 3.5ghz
8GB RAM (I have 16gb but it only says 8gb and I'm on 64 bit)
Nvidia GTX 960 2gb
Windows 8.1 64 bit
Sometimes it lags and sometimes it doesn't :/
 
P

Prefix_NA

Seasoned Member
Messages
3,770
Reaction score
963
1) make sure your ram is properly inserted and in the proper slots if you have 4 slots don't put them beside each other put them in the same color slots. If it is take it out and reinster it.

2) try each stick individually if above does not work maybe one is DOA

3) That GPU is a low end GPU it doesn't run games well try lowering draw distance to ~50% & grass to lowest (Grass is the most intensive feature I have noticed).
 
H

handsomepigeonzz

Enthusiast
Messages
223
Reaction score
12
I've tried everything with the RAM and it was new so I'm gonna test it on my friends PC. Thanks for the help what GPU would you recommend? (I just built my PC like 1 month ago so I'm a bit of a noob :/)
 
P

Prefix_NA

Seasoned Member
Messages
3,770
Reaction score
963
I've tried everything with the RAM and it was new so I'm gonna test it on my friends PC. Thanks for the help what GPU would you recommend? (I just built my PC like 1 month ago so I'm a bit of a noob :/)
380 woulda been a better card but I don't believe ur GPU is the issue just test 1 ram stick see if it boots then try the other.

If it doesn't boot with one of them its dead.

If your mobo has ram slots make sure they are in 1 & 2 not 1 & 3 the slots will be the same color if they are to be used together. Some mobo's might not recognize 1 & 3 properly.
 
H

handsomepigeonzz

Enthusiast
Messages
223
Reaction score
12
Yeah one of them is dead :/
 
B

BitTorrent

Enthusiast
Messages
563
Reaction score
125
1) make sure your ram is properly inserted and in the proper slots if you have 4 slots don't put them beside each other put them in the same color slots. If it is take it out and reinster it.

2) try each stick individually if above does not work maybe one is DOA

3) That GPU is a low end GPU it doesn't run games well try lowering draw distance to ~50% & grass to lowest (Grass is the most intensive feature I have noticed).
The 960 is not low end? It runs most games great.
 
Top Bottom