Issues with co-op campaign, or just H2A?

Discussion in 'Halo: MCC Support' started by Azsry, Dec 11, 2014 with 1 replies and 427 views.

  1. Azsry

    Azsry Getting There

    Messages:
    701
    Ratings:
    488
    As you all probably know, MCC has been plagued with 'Failed to connect' issues ever since launch. This happened all the way until the most recent update, but my friend and I were still able to get through Halo CE on Legendary.

    Now we've moved onto Halo 2 Anniversary where all WAS well until we hit the mission 'The Arbiter'. Whenever we start up the game, the loading screen for 'The Arbiter' appears, but soon after the host (we've tried both of us hosting, in vain) gets sent to the Halo:MCC loading screen and the other player sits on the loading screen for 'The Arbiter' while constantly getting error ping sounds. Afterwards we both get kicked to the main menu and can't even find each other in the Roster until we go to the Home screen and quit the game from the Menu button menu.

    I'm not sure if this happens for everyone else, if it only affects this mission (or H2A's campaign), or if it's because we're playing co-op, but we tried 3 player co-op on Halo 4 and it let us play properly. We have yet to try the previous or following missions in H2A's campaign, but right now it feels like it's just the whole campaign doesn't like co-op play.
     
  2. pmadra

    pmadra Newbie

    Messages:
    12
    Ratings:
    0
    Hey man same thing happened to myself and my friend, this for some reason worked for us inv your friend into your game and then promote him to leader and start the mission. If it doesnt work have him inv you and try idk if it will work but for some reason it did for us. Hope it helps :smile:
     

Share This Page