What's new

Unsolved iPhone 4 - Stuck "Searching" or "Fake" Signal.

M

Mattch

Enthusiast
Messages
814
Reaction score
121
Hey guys,

Ever since I've done the unteathered jailbreak for my iPhone 4 5.0.1 (about 3 - 4 months ago) I've had a recurring issue with the signal, I've checked google and contacted both Apple and Vodafone support to see if they have any ideas but its hard to get them to understand anything without saying its been jailbroken.

Basically, at random times (usually if the phone loses signal fully or is turned off) when it is turned back on / moves into an area with signal it'll just display "Searching..." but never actually find a signal, if I put it into airplane mode and then take it out it'll suddenly have a 3 bar connection yet the connection will never change and I cannot receive phone calls (Phone doesn't register them coming in) and send or receive texts - however the WI-FI still works fine.

The Only way I've found to fix this is to do either a "Reset Network Settings" which works, rarely, or a "Reset All Settings" which is getting annoying now.

Do you guys have any ideas - and sorry for the long post :tongue:

-Matt
 
Operating System
  1. iOS
S

Siri

What can i help you with ?
Messages
574
Reaction score
95
Yer same issue on iphone 4s i haven't found a full fix yet i just ignore another way might be to get a new sim
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
Totally forgot about this thread :oops: so sorry for the bump!

I've tried a new sim (just told them my old one snapped) but that hasn't solved the issue sadly :frown:
 
H

halopro77

The Wombologist
Messages
1,713
Reaction score
575
Sounds like a launch daemon problem? Just do a fresh restore to 5.1.1 and re jb. It sounds like you or a malicious process messed with your phones launch daemons (background services). A fresh restore will replace all of them with good ones
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
Sounds like a launch daemon problem? Just do a fresh restore to 5.1.1 and re jb. It sounds like you or a malicious process messed with your phones launch daemons (background services). A fresh restore will replace all of them with good ones

Possibly, although for some reason my phone won't show in iTunes, the mobile device service refuses to start and iTunes itself won't even connect to the store even though it shows my old iPod nano :@.
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
There are Other services need like bonjour and ipodservice. Try reinstalling iTunes then restoring your phone. Also check this out: http://support.apple.com/kb/TS1567

I've already tried to reinstall iTunes but that hasn't worked.

When I actually connect the iPhone it still recognizes it because it opens the auto play screen
75381063.png


But when I checked services, the Apple Mobile Device service hasn't even started and when I try to start it (with the phone connect) it just gives me this:

21852555.png



Both Bonjour and iPodService are running fine + the iPhone is charging off the computer (Which it doesn't when I uninstalled the Apple Mobile Service)

When I tried to connect to the store because I noticed that the Apple Mobile Device service has a dependency on the internet (TCP/IP Protocol Driver) iTunes gives me this:

68095854.png



Stupid question is: How do I restore the phone if it won't connect to iTunes?
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
Bump for attention
 
S

So Baked 7s

Newbie
Messages
5
Reaction score
9
Bump for attention
If you put it into DFU mode, your itunes will most likely recognize it then. Restore it to 5.1.1 and then re-jailbreak it. Thats the only solution I can propose because it sounds like a bug that might be fixed in 5.1.1.
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
If you put it into DFU mode, your itunes will most likely recognize it then. Restore it to 5.1.1 and then re-jailbreak it. Thats the only solution I can propose because it sounds like a bug that might be fixed in 5.1.1.

I've tried that and it won't even recognize DFU mode, it just states that:

"The iPhone software update server could not be contacted"

Most likely related to the:

68095854.png


Error I get
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
I think its more of an issue with my computer regarding the iTunes issue as my old laptop works 100% fine with the phone, connects to the store fine with pretty much all the same settings so I'm not sure exactly whats up.
 
M

Mattch

Enthusiast
Messages
814
Reaction score
121
Well got it working on another one so and it seems to have fixed the issue,

iTunes won't work on this PC for some reason though :frown:
 
Top Bottom