Help needed! Trying to flash BenQ with PCMCIA SATA on laptop

Discussion in 'Xbox 360 Support Archive' started by Tisco, Dec 12, 2008 with 3 replies and 8,970 views.

Thread Status:
Not open for further replies.
  1. Tisco

    Tisco Enthusiast

    Messages:
    3
    Ratings:
    0
    Hi everybody,

    I'm requesting help for flashing my BenQ drive. I've gone through tons of forums and they've gotten me to the point I'm in now. I can't seem to find information that would get me further, what either means that this is a dead end or then the last step until I succeed, since people are usually too busy to post the information online after they achieved their goal.

    -------------------------------------------------------------------

    I'm requesting help for flashing my BenQ drive. I start by telling what kind of hardware/software I'm using:

    Xbox 360:
    Falcon motherboard
    BenQ VAD6038 DVD drive

    Laptop hardware:
    Acer Aspire 5610 (1,6GHz, 2Gb)
    PCMCIA SATA card with VIA 6421 chipset(On Device Manager shows up as VIA RAID Controller - 3249)
    - On a side note, this PCMCIA card has two SATA ports at FBD0 and FBC0. I'm using the FBD0 one, since it's the one showing first in the I/O listing in System Information.

    Software:
    Windows XP SP3
    Dosflash v1.6

    I have a SATA cable running from my PCMCIA card to the BenQ SATA port. BenQ is getting it's power from Xbox 360 and I control that with the power button on 360.

    If You need more information about my system please ask.

    -------------------------------------------------------------------

    I'm sorry that this posting is quite long. I'm trying to give as much information as possible at this point to hopefully get the most accurate help. I've been spending few days on this now and I tried to go through forums to find help with no luck. I'm quite positive people have done this flashing with this setup, but when they have, they haven't taken the time to post the success story online. I'm sorry if I'm missing something obvious and please let me know if I am.

    I represent my conclusions and questions at this point and give more details on them beneath. So, before commenting the conclusions or giving answers to the questions please check the rest of this post to receive more details! My current state with my project can be found from section C2.

    Here's my conclusions so far and please correct me if You think I've overlooked something. Please check the rest of this post for more information.
    C1: I have to go with Dosflash32 v1.6
    C2: Dosflash32 does communicate with the BenQ drive
    C3: Timing plays an important part in switching the Xbox 360 on and off.
    C4: I'm going to use this setup to flash my BenQ.


    My questions so far, please answer any if You have ideas. Please check the rest of this post for more information.
    Q1: Is there a Tutorial on how to flash BenQ with a laptop using PC Card (PCMCIA) SATA card? (Plenty of information about flashing BenQ with a desktop computer, but I need a guide for laptop.)
    Q2: Should windows detect the Benq DVD drive of the Xbox 360? (My windows doesn't react to it any way)
    Q3: Can Xbox 360's own power system be used with flashing BenQ with a laptop?
    Q4: Is there a listing of the Dosflash status codes somewhere (0x80, 0xFF, 0xD1 etc.)? (Knowing them might help in solving the problem)
    Q5: Can You think of anything I've overlooked or doing something fundamentally wrong?


    -------------------------------------------------------------------

    More info

    C1: Seems that I have to do this flashing with Dosflash32, since that's the only way that has shown me some light in my efforts. I understand doing it by booting to DOS would be a better choice, but I'm quite doubtful of making the 32bit PCMCIA card working in 16bit DOS. I've tried to make an USB bootdisk and then disabled HDDs and ODDs physically (detached the devices). Note that the BIOS of this laptop is up to date (v3.50) and offers very little options for anything. Auto mode states that there's no ATAPI Devices Present and manual mode hangs firmly at 0xFF. I get the same result when I try to run Dosflash16 under command window in XP as well.

    C2: The furthest I've gotten at this point is to get Dosflash32 to regognize the BenQ drive. I managed to get the information of the drive to Dosflash32 by using the built in Magic 28 unlock method. When I tried to read the flash it hanged at Reading Bank 0 and the green "power on" light in Xbox was blinking. When nothing else happened in 15 minutes I turned the Xbox off and on again with no change in anything.

    Then there was a setback: I've been on this for few days and at some point my windows drastically slowed down, everything from booting up, using and shutting down was very delayed. I decided to restore the system with a configuration from a couple of days earlier. Windows started to work fine again, but I can't use the Magic 28 method anymore. Now both methods (Magic 28 and Geremia's) fail. When I try to do it in the "last" possible mode in Dosflash32 the drive status changes between 0x80 - 0xD0 - 0xD1 - 0x50 and 0x51 when I turn the power to BenQ drive on and off. I've managed to get an occasinal 0x90 status as well, but not the desired 0x73 no matter how often I boot. There might be a special timing or eject trick but I haven't been able to figure it out yet. At least this proves that there is a connection and communication between my laptop and the BenQ drive and this makes me believe that it can be done. At this point even if I managed to do it by pure luck I wouldn't care.

    C3: Different timing with the turning the Xbox on and off seems to give different Status readings.

    C4: I would love to use a desktop computer to get this over with, but my nearest friend with that kind of computer lives 3000 miles away. I live on coutryside and I don't want to keep ordering different pieces for my project here in hope to make it work. I know it can be done.

    -------------------------------------------------------------------

    I would REALLY appreciate any help and suggestions! Thank You for Your time!

    Little update:


    Now I get to the state just before reading the Flash every time using the Magic 28 method. I think the problem might have been either 1) that my Xbox 360 A/V was unplugged or 2) the timing with turning the Xbox on and starting up Dosflash32 was wrong.

    When I hit "Read Flash" Dosflash32 asks me for the filename and then does nothing. The status bar says "Reading Bank 0" and the green "power on" light of the Xbox keeps blinking (like it does when ejecting the drive).

    Q6: Should it say something under "Firmware Revision" at this point already?
    Here's an image before hitting "Read Flash":
    [Click here to view the link]

    And an image after hitting "Read Flash" and putting down the name and the location for the original firmware:
    [Click here to view the link]
     
  2. habbib

    habbib Newbie

    Messages:
    19
    Ratings:
    0
  3. funster

    funster Newbie

    Messages:
    2
    Ratings:
    0
    I cant see that it matters wheather you use a laptop or a desktop to be honest, its the sata controller thats the important thing.

    I have just flashed my Benq drive, but I used Jungle Flasher with win XP sp3 and followed the tutorial... very easy

    Oooops, sorry just seen how old original post is
     
  4. hackerjoe

    hackerjoe Newbie

    Messages:
    7
    Ratings:
    0
    I've tried 3 different laptops and 2 SATA PCMCIA card and cant get it to see any type of drive even a 3.5" hard drive. I'm begging to think it cant be done !

    Is there any particular laptop anyone has working I'd like to know please to go portable with :smile:

    Thanks
     
Thread Status:
Not open for further replies.