What's new

Tutorial Halo:Combat Evolved for Mac OSX (Works on El Capitan)

  • Thread starter goss34
  • Start date
  • Views 37,744
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
Update 7/21/18: All links have been updated and are now working!

After a couple weeks, I have finally managed to get Halo:CE working on my mid-2012 MacBook Pro running OSX El Capitan. Here are steps to get you running Halo on your Mac.

Before we start:
- Intel and PowerPC models only
- Multiplayer with PC models not tested (UPDATE: Works on PC versions that have been updated to 1.09, this update for PC is also available in the links below)
- Visit HaloMD for mods and multiplayer

Step 1
- Download the Halo Universal Binary here
- Download Halo Universal updater (2.0.4) [Click here to view this link]

a2DxcRM.png

Step 2
- Install the Binary
- Launch the game and use ZAXG-FAJM-YEU5-UW29 as the key code
- Install the update
- Launch the game and play!

Warnings!
- Make sure that your in-game internet settings match your current internet set-up. If your settings don't match your set-up it can cause the player in game to move slow and other bugs.
- If running an older Mac on the graphics settings make sure to select "Vertex Shaders Only", this will decrease bugs and increase performance. This will cause rocks to become invisible.

IF RUNNING MAVERICKS!
- Mavericks have a problem where the game doesn't run.
- Download the patch here and follow the readme instructions.
 
Last edited:
J

Jsolo

Newbie
Messages
3
Reaction score
1
Hi,

Thanks for this. I was able to get the game installed and it runs beautifully. Except for one thing, as you mentioned if the settings don't match your character will run slowly. I can't seem to get my settings to match up, can you tell me more specifically how to set them properly?

Thanks
 
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
Hi,

Thanks for this. I was able to get the game installed and it runs beautifully. Except for one thing, as you mentioned if the settings don't match your character will run slowly. I can't seem to get my settings to match up, can you tell me more specifically how to set them properly?

Thanks
In settings, there should be an option where you can choose your internet/connection type. That is what I am referring to. You need to select the type of connection you currently have in your home or are currently using. For example, if you use DSL, select DSL and the correct bandwidth selection. Hope this helps!
 
J

Jsolo

Newbie
Messages
3
Reaction score
1
In settings, there should be an option where you can choose your internet/connection type. That is what I am referring to. You need to select the type of connection you currently have in your home or are currently using. For example, if you use DSL, select DSL and the correct bandwidth selection. Hope this helps!

Hey,

So I've tried changing the network settings to every possible connection type but my character is still running extremely slow in the campaign mode. I'm just on a basic wifi connection. I don't understand why the internet connection type should affect the offline play. I noticed there is the section for Server / Client port, does it matter what those numbers are set to? :confused:
 
J

Jsolo

Newbie
Messages
3
Reaction score
1
Hey,

So I've tried changing the network settings to every possible connection type but my character is still running extremely slow in the campaign mode. I'm just on a basic wifi connection. I don't understand why the internet connection type should affect the offline play. I noticed there is the section for Server / Client port, does it matter what those numbers are set to? :confused:
In settings, there should be an option where you can choose your internet/connection type. That is what I am referring to. You need to select the type of connection you currently have in your home or are currently using. For example, if you use DSL, select DSL and the correct bandwidth selection. Hope this helps!

alright i figured out the problem. even though I'm not on mavericks os anymore I still needed to dl the patch. Everything is running just great. Thanks!
 
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
alright i figured out the problem. even though I'm not on mavericks os anymore I still needed to dl the patch. Everything is running just great. Thanks!
Glad you figured it out!
 
F

fordpotter

Newbie
Messages
1
Reaction score
0
Hi, trying to download, but the "here" links go to adf.ly and do nothing for me.
 
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
Hi, trying to download, but the "here" links go to adf.ly and do nothing for me.
Have you ever used ad.fly before? You have to wait a couple seconds and then click the skip ad button in the top right corner. One of the links is dead, I just checked it so I'll update it and get back to you when it's finished. 
All links should be working fine now.
 
N

Name John

Newbie
Messages
2
Reaction score
0
alright i figured out the problem. even though I'm not on mavericks os anymore I still needed to dl the patch. Everything is running just great. Thanks!
My character is still running slow. Installed latest update 2.0.4 and Mavericks patch but that didn't change anything. Using El Capitan and it works, except that everything is in slow motion. Any advice? iMac (27-inch, Late 2009)
 
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
I currently do not have my Mac anymore as it has broken and I have not taken the time to buy a new one, but I found a video that may be able to help you:



Please reply back and if this works, I'll update the original post (By the way, sorry for the late reply).

Try this link and download the first download patch and follow the steps in the video.
 
N

Name John

Newbie
Messages
2
Reaction score
0
I currently do not have my Mac anymore as it has broken and I have not taken the time to buy a new one, but I found a video that may be able to help you:
Please reply back and if this works, I'll update the original post (By the way, sorry for the late reply).
That finally worked! Turns out I had changed the name of the wrong app file. Video with time stamp helped. Thanks so much!
 
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
Has anyone found a way to get this working on OSX Mojave?
Sorry for the long reply. I have not been able to test this on new the new OS because I currently don't own a Macbook anymore. If you have the new OS, please try to follow the same steps and report back if you do!
 
Last edited:
J

JohnGeorge

Newbie
Messages
1
Reaction score
0
Just found this and have tried to get it to work, but it keeps asking for the disk to be inserted. Tried seeing whether it was the patch, but that didn't help either.
Im not sure if i've done something wrong
 
goss34

goss34

Shodan's Insect
Messages
334
Reaction score
131
Just found this and have tried to get it to work, but it keeps asking for the disk to be inserted. Tried seeing whether it was the patch, but that didn't help either.
Im not sure if i've done something wrong
Is there an option to skip the disk insert? If possible can you screenshot the page that asks for the disk?
 
L

liloldboy

Newbie
Messages
1
Reaction score
0
Does multiplayer work?
About to try and install on OS Mojave

EDIT:
Had a similar issue as above, it asks to insert a cd. Can't attach screenshot but message displays:

Please insert the CD "Halo Universal" into your CD-ROM drive, or press Quit to exit the game.

It only gives the option to quit.
 
Last edited:
corpse

corpse

Enthusiast
Messages
126
Reaction score
15
Here is what I did and didnt require a disk. basically install update before you run the game, unlike what it says in the original post.

1: install the game
2: apply the 2.0.4 update (you can try the included one, I just went for newest)
3: now launch the game
4: enter serial
5: play game.
it never asks for disk this way. mac osx 10.4 tiger. should be the same on everything though.
 

Similar threads

Top Bottom
Login
Register