Disconnects My Wireless Constantly!

Discussion in 'Microsoft Windows' started by x Freedom x, Feb 3, 2009 with 6 replies and 179 views.

  1. x Freedom x

    x Freedom x Enthusiast

    Messages:
    250
    Ratings:
    28
    Windows 7 keeps disconnecting my wireless almost every 15-180 minutes.

    I am not really sure what the problem could be I am using a Linksys WRT54G Wireless router and I am using a Linksys Wireless Adapter which I connect through USB.

     
  2. Eaton

    Eaton Contributor

    Messages:
    1,603
    Ratings:
    383
    I have the same router and I don't have any problems. Try updating the router's firmware and updated the wireless adapter driver.
     
  3. OP
    x Freedom x

    x Freedom x Enthusiast

    Messages:
    250
    Ratings:
    28
    Bump, Still having the same problem! Tried updating firmware still having troubles.
     
  4. Ibdc

    Ibdc Retired Retired

    Messages:
    5,100
    Ratings:
    2,072
    Do you have this problem on any other computers in your house? If you do then you need to contact your ISP, if you don't then it's a problem with your wireless adapter, not your router.
     
  5. Haxalot88

    Haxalot88 VIP VIP

    Messages:
    8,051
    Ratings:
    2,482
    This was the problem I was getting on my 54G before it finally died. Two things to try:
    - Upgrading the firmware (even if it's the latest version, upgrade to latest version).
    - Plug through LAN.

    Some 54g routers will just die, but that doesn't mean that the problem could be originating with other wireless problems.
     
  6. OP
    x Freedom x

    x Freedom x Enthusiast

    Messages:
    250
    Ratings:
    28
    I have 2 other computers in my house, Neither of them gets disconnected.
    I tried switching the Wireless Adapter not to long ago and it did nothing.


    I am almost 100% certain that it is Windows 7 causing this problem because it started to occur the day I installed the beta.
     
  7. ShadowZ

    ShadowZ Enthusiast

    Messages:
    1,364
    Ratings:
    198
    Do you have a cap card or your connections bridged? My pinnacle DVD recorder seems to screw up my computer if I boot up my computer with it connected. I have the same setup except I have XP installed but this could be the problem. I would also try unplugging everything in your usb ports except obviously your mouse, keyboard and adapter and restart it to see if that works.