What's new

Solved Advice On Purchasing A Nand-X???

V

ViperishMist

Newbie
Messages
18
Reaction score
0
So lately I've been wanting to get a Nand-X for myself since I'm always using my friends, which he purchased way back in 2015 off eBay for about $50CAD. For the past month I have been searching eBay almost every day and I never sees a single Nand-X go up for sale, and I have a JR Programmer V2 but it must be bricked or something because I can't get the bootloader to show up in JRunner to update it and it NEVER even attempts to read the Nand off a console at all. So I did some searching of my own and discovered that you can get one on Ali-express for about $45CAD which sounds pretty reasonable to me, although I dont know if when I get the Nand-X will it function the way it should since its from China meaning its probably a clone or will it already be broken or etc. (Although I could be wrong, correct me if I am!)

So on that note, I was wondering if it would be a good idea to go ahead with it or not, attempt to find another way to fix my JR Programmer V2, or buy some sort of other programmer for the nand reading. Because I really REALLY wanna get into RGHing consoles so badly!! :tongue:
 
T

TheCoolDave

Newbie
Messages
15
Reaction score
3
Yeah, those guys don't use PayPal which for some reason I dont feel comfortable with. And for me its over $60CAD, which isn't too bad but damn. ?

Although if someone thinks there is a way to fix my JR-Programmer V2 let me know because that would be appreciated.

Had the same problem on the JR programmer, V2 Posted on Reddit, I updated my first post. You have to re-flash the firmware to the JR-programmer.


Trying to use this thing maybe 30-40 times doing timings, this happened 3-4 times and takes like 30 seconds to get it running again.

Good luck
 
V

ViperishMist

Newbie
Messages
18
Reaction score
0
Had the same problem on the JR programmer, V2 Posted on Reddit, I updated my first post. You have to re-flash the firmware to the JR-programmer.


Trying to use this thing maybe 30-40 times doing timings, this happened 3-4 times and takes like 30 seconds to get it running again.

Good luck
Yeah with mine its a completely different story. I can't get the bootloader to pop up period, the red light stays on no matter what combination of switches on the thing I use, and when the green light does come on, it still never reads any nands or program any glitch chips.. So I try to select the option to update the firmware and I keep getting errors saying "Device not found" and once again I keep trying all combination of switches on the board and I try unplugging it and plugging it in multiple times and hitting the reset button on it but still not a damn thing.

And this brings me to the whole thing on should I attempt to get a nand-x and pay the premium for it. If I can get this thing working, I will be set. But right now it just pisses me off so damn much...

But thank you for sharing that though, and I'm glad to hear that you got yours fixed!!
 
T

TheCoolDave

Newbie
Messages
15
Reaction score
3
Yeah with mine its a completely different story. I can't get the bootloader to pop up period, the red light stays on no matter what combination of switches on the thing I use, and when the green light does come on, it still never reads any nands or program any glitch chips.. So I try to select the option to update the firmware and I keep getting errors saying "Device not found" and once again I keep trying all combination of switches on the board and I try unplugging it and plugging it in multiple times and hitting the reset button on it but still not a damn thing.

And this brings me to the whole thing on should I attempt to get a nand-x and pay the premium for it. If I can get this thing working, I will be set. But right now it just pisses me off so damn much...

But thank you for sharing that though, and I'm glad to hear that you got yours fixed!!

Are you using Windows 10 ? This is the same issue I saw on Windows 10... Get yourself a old Windows 7 laptop, or even XP. And try again.

I so happened to have a very old Dual core laptop that has Windows 7 x86 on it. I use it for Techstream (my car software) and I used that, after I tried to flash it on Windows 7, even with out being shown in the event viewer, it flashed perfectly. Only thing I would see is in J-Runner "boot loader device detected"

You can get some Virtual machine software for free that will pass USB over, I was going to do this but because I had a laptop, I used that.
 
V

ViperishMist

Newbie
Messages
18
Reaction score
0
Are you using Windows 10 ? This is the same issue I saw on Windows 10... Get yourself a old Windows 7 laptop, or even XP. And try again.

I so happened to have a very old Dual core laptop that has Windows 7 x86 on it. I use it for Techstream (my car software) and I used that, after I tried to flash it on Windows 7, even with out being shown in the event viewer, it flashed perfectly. Only thing I would see is in J-Runner "boot loader device detected"

You can get some Virtual machine software for free that will pass USB over, I was going to do this but because I had a laptop, I used that.
If I can remember, every PC in my house and at my friends house has windows 10 on it so I will have to find out a way on how to set up a virtual machine on my current computer. Is there a site or anything that I can get some advice on how to get a virtual machine up and running? Because I seen people use them before in a lot of videos I watch, but I never really thought about how I would ever get it running on my own computer. Like if it could corrupt something, would it work on NVMe, how would I get it to detect the USB in my PC, etc.
 
T

TheCoolDave

Newbie
Messages
15
Reaction score
3
If I can remember, every PC in my house and at my friends house has windows 10 on it so I will have to find out a way on how to set up a virtual machine on my current computer. Is there a site or anything that I can get some advice on how to get a virtual machine up and running? Because I seen people use them before in a lot of videos I watch, but I never really thought about how I would ever get it running on my own computer. Like if it could corrupt something, would it work on NVMe, how would I get it to detect the USB in my PC, etc.

Install VM software, Find ISO file of Windows 7 or XP (should not be hard google is your friend.), Create new VM, follow the wizard, it will ask you what OS, and where the install files are. Let it go, then when the OS installs, follow the wizard, skip a key and once all done you will have a trial of Windows 7 or XP.

Then do you what you need.

Or go on ebay, look for a USED Windows 7 laptop, they should be cheap, under $75...You don't need anything special, I was using a dual core first or 2nd gen... really, really old...
 
V

ViperishMist

Newbie
Messages
18
Reaction score
0
Install VM software, Find ISO file of Windows 7 or XP (should not be hard google is your friend.), Create new VM, follow the wizard, it will ask you what OS, and where the install files are. Let it go, then when the OS installs, follow the wizard, skip a key and once all done you will have a trial of Windows 7 or XP.

Then do you what you need.

Or go on ebay, look for a USED Windows 7 laptop, they should be cheap, under $75...You don't need anything special, I was using a dual core first or 2nd gen... really, really old...
I got a Windows 7 VM running, and it did the exact same thing with the JR-Programmer V2 saying device not found. I installed drivers for it on the VM just like I did on Windows 10, tried all combination of switches and still nothing. Used the exact same USB connector and yes JRunner detected it and everything but it still wont read any nands and I still cant update it. So either I'm still doing something wrong, or the chip itself is completely dead. :/
 
T

TheCoolDave

Newbie
Messages
15
Reaction score
3
I got a Windows 7 VM running, and it did the exact same thing with the JR-Programmer V2 saying device not found. I installed drivers for it on the VM just like I did on Windows 10, tried all combination of switches and still nothing. Used the exact same USB connector and yes JRunner detected it and everything but it still wont read any nands and I still cant update it. So either I'm still doing something wrong, or the chip itself is completely dead. :/

OK, once moved over to the VM, does it show as a bootloader connected ? Or does the JR logo show ?

When trying to flash it, you need to select the PICFLASH_E_1_0_5-JRP-V2.HEX to flash it with...

Trust me, I ran into this... Windows 10 was a big no no...
 
V

ViperishMist

Newbie
Messages
18
Reaction score
0
OK, once moved over to the VM, does it show as a bootloader connected ? Or does the JR logo show ?

When trying to flash it, you need to select the PICFLASH_E_1_0_5-JRP-V2.HEX to flash it with...

Trust me, I ran into this... Windows 10 was a big no no...
When I was in JRunner, it showed the logo for the chip and I tried for over an hour to get the bootloader to pop up and it never came up once. And yes, that is the file I was trying to flash it with but it kept saying "no device found". Keep in mind, all of this was done in the Windows 7 VM.
 
T

TheCoolDave

Newbie
Messages
15
Reaction score
3
When I was in JRunner, it showed the logo for the chip and I tried for over an hour to get the bootloader to pop up and it never came up once. And yes, that is the file I was trying to flash it with but it kept saying "no device found". Keep in mind, all of this was done in the Windows 7 VM.

When I flashed it, Windows didn't even detect it. Did you got to the device manager, what does it show as ?
 
V

ViperishMist

Newbie
Messages
18
Reaction score
0
When I flashed it, Windows didn't even detect it. Did you got to the device manager, what does it show as ?
When on device manager on windows 7, it shows up in device manager under "PRUFTECHNIK USB DEVICES" saying it's "XECUTER JR-PROGRAMMER", and keep in mind that's what it says it is when the green light on the chip is on. As soon as the red light comes on when unplug it and plug it back in again is comes up as "Unknown Device" and wont even show up period in JRunner.
 
T

TheCoolDave

Newbie
Messages
15
Reaction score
3
When on device manager on windows 7, it shows up in device manager under "PRUFTECHNIK USB DEVICES" saying it's "XECUTER JR-PROGRAMMER", and keep in mind that's what it says it is when the green light on the chip is on. As soon as the red light comes on when unplug it and plug it back in again is comes up as "Unknown Device" and wont even show up period in JRunner.

When it goes to unknow device, does flashing do anything ?
 
V

ViperishMist

Newbie
Messages
18
Reaction score
0
When it goes to unknow device, does flashing do anything ?
It still keeps saying unknown device and does nothing at all and the red light on it stays solid at all times until I unplug it. :/
 
Top Bottom