1. Think you have what it takes to join staff? Click here and check out the Staff thread to find out more information!
  2. Looking to spice up your game collection with a copy of the highly anticipated Bungie title Destiny? Hop on your ship and engage its hyper drive, this contest is going to be a heated one! Visit the contest by clicking here.
  3. Hello Guest, our very own Vanilla Minecraft Server is now up! Be sure to grab a few friends and check out the server here so that you guys can start your very own faction! Check it out HERE!
  4. Community Update: The Community Champion Events will soon be coming to a close, be sure to get your votes in!

    ToTMCoTMEoTM

Xbox 360 DvD drive issue!?

Discussion in 'Xbox 360 Support' started by Xterestrial, Feb 12, 2013 with 3 replies and 389 views.

  1. Xterestrial

    Xterestrial Newbie

    Messages:
    2
    Likes Received:
    0
    Okay. so i have been working endlessly for the last 3 days NON Stop.
    to rid a Spare Xbox of RROD for my GF's Valentine's Present.

    My console is Now RROD free.
    But a new problem is here.
    i noticed the Dvd drive wouldn't open.
    and the green Disc tray light was blinking.
    i hit eject. the Xbox Says Closing opening Etc.
    But does nothing.
    the light stays blinking.

    so i took the drive and but it in another 360 (Mine)the drive opens. closes. Just fine.

    i took MY dvd drive. and hooked it to the one im fixing.
    and it just blinks Straight from Boot.
    and does the same Previous stuff.

    How do i fix it?
  2. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,123
    Likes Received:
    1,956
    Are they're any bent pins on the mobo? Otherwise this is gonna be a hard one and require extensive multimeter testing to figure out where the power is failing to get to the DVD drive.
  3. binarycsy

    binarycsy Newbie

    Messages:
    12
    Likes Received:
    0
    did any one get the fix ???
  4. binarycsy

    binarycsy Newbie

    Messages:
    12
    Likes Received:
    0
    any fix for this