1.  

Problem accessing NXE after update to dash

Discussion in 'Xbox 360 Support' started by Christianmoel, Sep 14, 2013 with 4 replies and 340 views.

  1. Christianmoel

    Christianmoel Newbie

    Messages:
    8
    Likes Received:
    0
    Hello i recently updated to dashboard 16537. I followed the instruction posted in this tutorial:
    http://geekbone.blogspot.dk/2013/04/tutorial-how-to-update-xbox360-to-latest-dashboard.html

    My xbox is a RGH, with a JASPER v4.0 motherboard 512Mb

    Problem is that i can by no means known to me access NXE anymore. i have tried home + RB, along with miniblade options like family settings and so on. The result of this i a FSD boot screen shortly after i release RB.
    I have also tried to remove the harddisk to force it to start NXE, but it just freezes at the xbox icon. Stragely it seems that the update worked, i am able to play xbox arcade games along with games like injustice, which were not possible before.

    I haven't modded the xbox myself, so at that point i have little experience. But having owned the modded xbox for some time im not totally clueless. I want to note that i flashed the nand as in the tutorial twice. The first time i mistakingly forgot to change it from Jasper 256Mb to 512Mb.
    After that i redid the process using the correct motherboard model, note that i used the same Nand dump as the previous update it matters anything.
    .
    As said im still pretty new to this and i was hoping some more experienced people may have a solution to the problem. Any input will be much appreciated :)
    I also have one question, can i flash the nand with a older dashboard version? like 16203. And would that make any difference?

    launch.ini

    [QuickLaunchButtons]
    Default = hdd:\FreeStyle\default.xex
    [Settings]
    nxemini = true
    pingpatch = true
    contpatch = true
    fatalfreeze = false
    fatalreboot = true
    regionspoof = true
    dvdexitdash = false
    xblaexitdash = true
    nosysexit = false
    exchandler = true
    noupdater = true
    debugout = false
    liveblock = true
    livestrong = false
    remotenxe = true
    nohud = false
  2. Christianmoel

    Christianmoel Newbie

    Messages:
    8
    Likes Received:
    0
    Figured id post the Jrunner log from the newest XellBuild Image.

    base path changed to C:\Users\christian3\Desktop\J-Runner\xeBuild
    ---- { Image Build Mode } ----
    building glitch image
    <enter> key on completion suppressed
    data directory overridden from command line to '16537\'
    per build directory overridden from command line to 'data\'
    file name overridden from command line to 'C:\Users\christian3\Desktop\J-Runner\003512393905\updflash.bin'

    ------ parsing user ini at 'data\options.ini' ------
    loading file...done!
    pre-parsing and sanitizing
    done!
    User options.ini loaded, 0x1b0 bytes in memory
    loading cpukey.txt from data\cpukey.txt
    CPU Key set to: 0x007383D80E5B8E9F814BB9B9F44B6CE3 (weight:0x35 valid; ecd: valid)
    setting 1blkey from ini: 0xDD88AD0C9ED669E7B56794FB68563EFA
    1BL Key set to: 0xDD88AD0C9ED669E7B56794FB68563EFA sum: 0x983 (expects: 0x983)
    xex Key set to: 0x20B185A59D28FDC340583FBB0896BF91 sum: 0x800 (expects: 0x800)
    Using patchsmc option (ini file)

    ------ parsing ini at '16537\_glitch.ini' ------
    ini version 16537

    ini: label [jasperbl] found
    found (1) 'cb_6750.bin' crc: 0xf7afa8cc
    found (2) 'none' crc: 0x00000000
    found (3) 'cd_8453.bin' crc: 0x25e0acd0
    found (4) 'ce_1888.bin' crc: 0xff9b60df
    found (5) 'cf_16537.bin' crc: 0xd2f70347
    found (6) 'cg_16537.bin' crc: 0xcf8a8c3c

    ini: label [flashfs] found
    found (1) 'aac.xexp' crc: 0x340f017f
    found (2) 'bootanim.xex' crc: 0x1a64dd1c
    found (3) 'createprofile.xex' crc: 0xbb5dfa34
    found (4) 'dash.xex' crc: 0x40671195
    found (5) 'deviceselector.xex' crc: 0xf80b066f
    found (6) 'gamerprofile.xex' crc: 0xb55d0d4f
    found (7) 'hud.xex' crc: 0xd1e27e82
    found (8) 'huduiskin.xex' crc: 0x98c75ba1
    found (9) 'mfgbootlauncher.xex' crc: 0x773ee67d
    found (10) 'minimediaplayer.xex' crc: 0x0411007d
    found (11) 'nomni.xexp' crc: 0x323c6e47
    found (12) 'nomnifwk.xexp' crc: 0xbe5a4208
    found (13) 'nomnifwm.xexp' crc: 0xc9c3f0e0
    found (14) 'SegoeXbox-Light.xtt' crc: 0xe0ee6049
    found (15) 'signin.xex' crc: 0x4dd243b2
    found (16) 'updater.xex' crc: 0xe93cef2e
    found (17) 'vk.xex' crc: 0xac383a80
    found (18) 'xam.xex' crc: 0x18496d9a
    found (19) 'xenonclatin.xtt' crc: 0xd5d17ff5
    found (20) 'xenonclatin.xttp' crc: 0x7a507ad1
    found (21) 'xenonjklatin.xtt' crc: 0xdde4a14c
    found (22) 'xenonjklatin.xttp' crc: 0xe2adddfb
    found (23) 'ximecore.xex' crc: 0xc558548c
    found (24) 'ximedic.xex' crc: 0x1d992bfb
    found (25) 'ximedic.xexp' crc: 0x4da51d92
    found (26) '..\launch.xex' crc: 0x00000000
    found (27) '..\lhelper.xex' crc: 0x00000000
    found (28) '..\launch.ini' crc: 0x00000000

    ini: label [security] found
    found (1) 'crl.bin' crc: 0x00000000
    found (2) 'dae.bin' crc: 0x00000000
    found (3) 'extended.bin' crc: 0x00000000
    found (4) 'fcrt.bin' crc: 0x00000000
    found (5) 'secdata.bin' crc: 0x00000000
    ------ ini parsing completed ------

    output name overridden to: C:\Users\christian3\Desktop\J-Runner\003512393905\updflash.bin

    1BL RSA pub key file is not available, signature checks will not be performed
    PIRS RSA pub key file is not available, signature checks will not be performed
    MASTER RSA pub key file is not available, signature checks will not be performed

    ------ Checking data\nanddump.bin ------
    data\nanddump.bin file size: 0x4200000
    nanddump header checks passed OK!
    Loading NAND dump (0x4200000 bytes)...done!
    Detecting NAND controller type from dump data...
    NAND dump is from a big block machine
    NAND dump uses big block controller
    parsing dump into user and spare...
    bad block at 0x182 (raw offset 0x31c2000), block ignored
    bad block at 0x183 (raw offset 0x31e3000), block ignored
    copying nanddump data from block 0x1fe to block 0x183 for file extraction integrity
    block 0x183 was remapped to block 0x1fe at remap instance 1
    copying nanddump data from block 0x1ff to block 0x182 for file extraction integrity
    block 0x182 was remapped to block 0x1ff at remap instance 0
    done!
    cleaning up stray remaps
    done!
    --remap summary--
    0: source: 0x0182 dest: 0x01ff
    1: source: 0x0183 dest: 0x01fe
    -----------------
    decrypting KeyVault at address 0x4000 of size 0x4000
    keyvault decrypted OK, will use if no kv.bin is provided
    decrypting SMC at address 0x1000 of size 0x3000
    SMC decrypted OK, will use if no external smc.bin is provided
    seeking smc config in dump...found at offset 0x3be0000! Using if no smc config is provided.
    CF slot 0 decrypted ok LDV 0x02 Pairing: 0x000000
    setting LDV from image to 2
    setting pairing data from image to 0x000000
    MobileB.dat found at page 0x1c700, size 2048 (0x800) bytes
    MobileC.dat found at page 0x1c704, size 512 (0x200) bytes
    MobileD.dat found at page 0x1c708, size 2048 (0x800) bytes
    MobileE.dat found at page 0x1c70c, size 1536 (0x600) bytes
    Statistics.settings found at page 0xef000, size 4096 (0x1000) bytes
    seeking FSRoot...fsroot found at page 0x1c800 raw offset 0x6648000
    seeking security files...
    crl.bin found in sector 0x34f size 0xa00...verified! Will use if external file not found.
    dae.bin found in sector 0x350 size 0xad30...verified! Will use if external file not found.
    extended.bin found in sector 0x353 size 0x4000...verified! Will use if external file not found.
    secdata.bin found in sector 0x354 size 0x400...verified! Will use if external file not found.
    done!
    Writing initial header to flash image

    ------ loading system update container ------
    16537\su20076000_00000000 found, loading...done!
    Read 0xb34000 bytes to memory
    checking integrity...
    header seems valid, version 2.0.16537.0
    header hash is OK, checking content hashes...
    content hashes seem OK, everything looks good!
    extracted SUPD\xboxupd.bin (0x7a010 bytes)
    decrypting SUPD\xboxupd.bin\CF_16537.bin (0x4560 bytes)...done!
    decrypting SUPD\xboxupd.bin\CG_16537.bin (0x75aa2 bytes)...done!

    ------ Loading bootloaders and required security files ------
    reading data\smc.bin failed, using smc.bin from nand dump
    reset smc load address to 0x1000 size 0x3000
    reading data\kv.bin failed, using kv.bin from nand dump
    reading .\common\cb_6750.bin (0x9a40 bytes)
    loaded cb_6750.bin, could not check signature rsa key not present!
    reading .\common\cd_8453.bin (0x5780 bytes)
    reading .\common\ce_1888.bin (0x5606a b pad 0x56070 b)
    reading data\xell-gggggg.bin (0x40000 bytes)
    extracted SUPD\xboxupd.bin\CF_16537.bin (0x4560 bytes)
    extracted SUPD\xboxupd.bin\CG_16537.bin (0x75aa2 bytes)
    reading 16537\bin\patches_fat.bin (0x86c bytes)
    reading data\smc_config.bin failed, using smc_config.bin from nand dump
    -------------------
    checking smc_config
    -------------------
    extracting config
    ------------------
    SMC config info:
    ------------------
    Target temps: Cpu: 80øC Gpu: 75øC Edram: 77øC
    Max temps : Cpu: 95øC Gpu: 90øC Edram: 92øC
    Cpu Fan : (auto)
    Gpu Fan : (auto)
    MAC Address : 00:25:ae:09:bd:f8
    AVRegion : 0x00000300 (PAL50)
    GameRegion : 0x02fe (PAL/EU)
    DVDRegion : 2
    resetKey : LLDX
    ---------------------
    Checking for smc config data patches
    smc config was not patched
    ---------------------
    done!
    patch slot offset reset to: 0xc0000

    ------ Patching BLs and modifying patches ------
    Patching BLs...Done!

    ------ Patching boot reasons and options into flash header ------
    Patching header for xell power reason

    ------ Encrypting and finalizing bootloaders ------
    initializing static pairing value
    encoding smc.bin size 0x3000
    SMC checksum: dbda8bb1
    unknown SMC found, type: Jasper v4.1(2.03)
    glitch hack found in smc.bin!
    encoding kv.bin size 0x4000
    decrypted keyvault has been set for reference
    Master RSA pub not available, not checking hash
    encoding cb_6750.bin size 0x9a40
    CB 6750 seq 0x01070050 type: 0x01 cseq: 0x07 allow: 0x0050
    expected fuses:
    fuseset 00: C0FFFFFFFFFFFFFF
    fuseset 01: 0F0F0F0F0F0F0FF0
    fuseset 02: 000000F000000000 (sequence)
    fuseset 02: 0000F00000000000 (allow cseq 5)
    fuseset 02: 000000F000000000 (allow cseq 7)
    encoding cd_8453.bin size 0x5b00
    encoding ce_1888.bin size 0x56070
    encoding xell-gggggg.bin size 0x40000
    encoding cf_16537.bin size 0x4560
    encoding cg_16537.bin size 0x75ab0
    encoding patches_fat.bin size 0x4b0
    done!

    ------ Adding bootloaders to flash image ------
    adding smc.bin at raw offset 0x00001000 len 0x3000 (end 0x4000)
    adding kv.bin at raw offset 0x00004000 len 0x4000 (end 0x8000)
    adding cb_6750.bin at raw offset 0x00008000 len 0x9a40 (end 0x11a40)
    adding cd_8453.bin at raw offset 0x00011a40 len 0x5b00 (end 0x17540)
    adding ce_1888.bin at raw offset 0x00017540 len 0x56070 (end 0x6d5b0)
    adding xell-gggggg.bin at raw offset 0x00070000 len 0x40000 (end 0xb0000)
    adding cf_16537.bin at raw offset 0x000c0000 len 0x4560 (end 0xc4560)
    adding cg_16537.bin at raw offset 0x000c4560 len 0x75ab0 (end 0xe0000, rest in fs)
    adding patches_fat.bin at raw offset 0x000e0010 len 0x4b0 (end 0xe04c0)
    Writing zeropair CG patch slot overflow data to sysupdate.xexp1
    at raw offset 0x2b80000 len 0x0005a010 (end: 0x02bda010)...done!

    ------ adding 28 firmware files ------
    extracted SUPD\aac.xexp (0x14000 bytes) (crc32: 0x340f017f ini: 0x340f017f)
    adding as aac.xexp1 at raw offset 0x2bda010 len 0x00014000 (end 0x02bee010)
    extracted SUPD\bootanim.xex (0x61000 bytes) (crc32: 0x1a64dd1c ini: 0x1a64dd1c)
    adding as bootanim.xex at raw offset 0x2bf0000 len 0x00061000 (end 0x02c51000)
    extracted SUPD\createprofile.xex (0xc000 bytes) (crc32: 0xbb5dfa34 ini: 0xbb5dfa34)
    adding as createprofile.xex at raw offset 0x2c51000 len 0x0000c000 (end 0x02c5d000)
    extracted SUPD\dash.xex (0x597000 bytes) (crc32: 0x40671195 ini: 0x40671195)
    adding as dash.xex at raw offset 0x2c60000 len 0x00597000 (end 0x031f7000)
    extracted SUPD\deviceselector.xex (0xa000 bytes) (crc32: 0xf80b066f ini: 0xf80b066f)
    adding as deviceselector.xex at raw offset 0x31f7000 len 0x0000a000 (end 0x03201000)
    extracted SUPD\gamerprofile.xex (0x1b000 bytes) (crc32: 0xb55d0d4f ini: 0xb55d0d4f)
    adding as gamerprofile.xex at raw offset 0x3202000 len 0x0001b000 (end 0x0321d000)
    extracted SUPD\hud.xex (0x1d000 bytes) (crc32: 0xd1e27e82 ini: 0xd1e27e82)
    adding as hud.xex at raw offset 0x321f000 len 0x0001d000 (end 0x0323c000)
    extracted SUPD\huduiskin.xex (0x14000 bytes) (crc32: 0x98c75ba1 ini: 0x98c75ba1)
    adding as huduiskin.xex at raw offset 0x323d000 len 0x00014000 (end 0x03251000)
    extracted SUPD\mfgbootlauncher.xex (0x8000 bytes) (crc32: 0x773ee67d ini: 0x773ee67d)
    adding as mfgbootlauncher.xex at raw offset 0x3254000 len 0x00008000 (end 0x0325c000)
    extracted SUPD\minimediaplayer.xex (0xc000 bytes) (crc32: 0x0411007d ini: 0x0411007d)
    adding as minimediaplayer.xex at raw offset 0x325c000 len 0x0000c000 (end 0x03268000)
    extracted SUPD\nomni.xexp (0xc800 bytes) (crc32: 0x323c6e47 ini: 0x323c6e47)
    adding as nomni.xexp1 at raw offset 0x3268000 len 0x0000c800 (end 0x03274800)
    extracted SUPD\nomnifwk.xexp (0x2000 bytes) (crc32: 0xbe5a4208 ini: 0xbe5a4208)
    adding as nomnifwk.xexp1 at raw offset 0x3274800 len 0x00002000 (end 0x03276800)
    extracted SUPD\nomnifwm.xexp (0x5000 bytes) (crc32: 0xc9c3f0e0 ini: 0xc9c3f0e0)
    adding as nomnifwm.xexp1 at raw offset 0x327a000 len 0x00005000 (end 0x0327f000)
    extracted SUPD\SegoeXbox-Light.xtt (0x6000 bytes) (crc32: 0xe0ee6049 ini: 0xe0ee6049)
    adding as SegoeXbox-Light.xtt at raw offset 0x3281000 len 0x00006000 (end 0x03287000)
    extracted SUPD\signin.xex (0x19000 bytes) (crc32: 0x4dd243b2 ini: 0x4dd243b2)
    adding as signin.xex at raw offset 0x328a000 len 0x00019000 (end 0x032a3000)
    extracted SUPD\updater.xex (0x7000 bytes) (crc32: 0xe93cef2e ini: 0xe93cef2e)
    adding as updater.xex at raw offset 0x32a5000 len 0x00007000 (end 0x032ac000)
    extracted SUPD\vk.xex (0xb000 bytes) (crc32: 0xac383a80 ini: 0xac383a80)
    adding as vk.xex at raw offset 0x32af000 len 0x0000b000 (end 0x032ba000)
    extracted SUPD\xam.xex (0x253000 bytes) (crc32: 0x18496d9a ini: 0x18496d9a)
    adding as xam.xex at raw offset 0x32bb000 len 0x00253000 (end 0x0350e000)
    extracted nanddump\xenonclatin.xtt (0x11b000 bytes) (crc32: 0xd5d17ff5 ini: 0xd5d17ff5)
    adding as xenonclatin.xtt at raw offset 0x350f000 len 0x0011b000 (end 0x0362a000)
    extracted SUPD\xenonclatin.xttp (0x18000 bytes) (crc32: 0x7a507ad1 ini: 0x7a507ad1)
    adding as xenonclatin.xttp1 at raw offset 0x362b000 len 0x00018000 (end 0x03643000)
    extracted nanddump\xenonjklatin.xtt (0x1a8000 bytes) (crc32: 0xdde4a14c ini: 0xdde4a14c)
    adding as xenonjklatin.xtt at raw offset 0x3644000 len 0x001a8000 (end 0x037ec000)
    extracted SUPD\xenonjklatin.xttp (0x7000 bytes) (crc32: 0xe2adddfb ini: 0xe2adddfb)
    adding as xenonjklatin.xttp1 at raw offset 0x37ec000 len 0x00007000 (end 0x037f3000)
    extracted SUPD\ximecore.xex (0x17000 bytes) (crc32: 0xc558548c ini: 0xc558548c)
    adding as ximecore.xex at raw offset 0x37f3000 len 0x00017000 (end 0x0380a000)
    extracted nanddump\ximedic.xex (0x90000 bytes) (crc32: 0x1d992bfb ini: 0x1d992bfb)
    adding as ximedic.xex at raw offset 0x380b000 len 0x00090000 (end 0x0389b000)
    extracted SUPD\ximedic.xexp (0x2800 bytes) (crc32: 0x4da51d92 ini: 0x4da51d92)
    adding as ximedic.xexp1 at raw offset 0x389c000 len 0x00002800 (end 0x0389e800)
    reading 16537\..\launch.xex (0xc800 bytes)
    adding as launch.xex at raw offset 0x389e800 len 0x0000c800 (end 0x038ab000)
    reading 16537\..\lhelper.xex (0x6000 bytes)
    adding as lhelper.xex at raw offset 0x38ac800 len 0x00006000 (end 0x038b2800)
    reading 16537\..\launch.ini (0x1cb bytes)
    adding as launch.ini at raw offset 0x38b6000 len 0x000001cb (end 0x038b61cb)

    ------ adding 5 security files ------
    <- Processing crl.bin ->
    reading data\crl.bin (0xa00 bytes)
    crl appears crypted, attempting to decrypt with CPU key...failed! Trying alternate key...success!
    adding as crl.bin at raw offset 0x38bc000 len 0x00000a00 (end 0x038bca00)

    <- Processing dae.bin ->
    reading data\dae.bin (0xad30 bytes)
    dae appears encrypted, attempting to decrypt with CPU key...failed! Attempting to decrypt with alternate key...
    success!
    adding as dae.bin at raw offset 0x38c0000 len 0x0000ad30 (end 0x038cad30)

    <- Processing extended.bin ->
    reading data\extended.bin (0x4000 bytes)
    adding as extended.bin at raw offset 0x38cc000 len 0x00004000 (end 0x038d0000)

    <- Processing fcrt.bin ->
    fcrt.bin not found and not required by keyvault, skipped

    <- Processing secdata.bin ->
    reading data\secdata.bin (0x400 bytes)
    adding as secdata.bin at raw offset 0x38d0000 len 0x00000400 (end 0x038d0400)

    ------ checking for Mobile*.dat ------
    MobileB.dat found, adding from previous parse
    adding MobileB.dat as type 0x31 at raw offset 0x38e0000 len 0x800 (end 0x38e0800)
    MobileC.dat found, adding from previous parse
    adding MobileC.dat as type 0x32 at raw offset 0x38e0800 len 0x200 (end 0x38e0a00)
    MobileD.dat found, adding from previous parse
    adding MobileD.dat as type 0x33 at raw offset 0x38e1000 len 0x800 (end 0x38e1800)
    MobileE.dat found, adding from previous parse
    adding MobileE.dat as type 0x34 at raw offset 0x38e1800 len 0x600 (end 0x38e1e00)
    Statistics.settings found, adding from previous parse
    adding Statistics.settings at raw offset 0x3bc0000 len 0x1000 (end 0x3bc1000)

    ------ adding smc_config.bin ------
    adding smc config to offset 0x03be0000, len 0x400

    ------ finalizing image ------
    Fixing up empty FS block entries...done!
    Writing FS table to image offset 0x3900000 len 0x4000 (end 0x3904000)...done!
    fixing up big block LBA numbers in spare...done!
    calculating ECD bytes and assembling raw image...done!
    remapping 2 blocks
    copying 0x21000 bytes of LBA 0x182 to block 0x1ff...zero fill origin...done!
    copying 0x21000 bytes of LBA 0x183 to block 0x1fe...zero fill origin...done!
    done remapping!

    ------ writing image to disk ------
    writing file 'C:\Users\christian3\Desktop\J-Runner\003512393905\updflash.bin' to disk...done!
    ---------------------------------------------------------------
    C:\Users\christian3\Desktop\J-Runner\003512393905\updflash.bin image built, info:
    ---------------------------------------------------------------
    Kernel : 2.0.16537.0
    Console : Jasper (big block)
    NAND size : 64MiB (system only)
    Build : Glitch
    Xell : power on console with console eject button
    Serial : 003512393905
    ConsoleId : 024836664245
    MoboSerial: 705637F230609385
    Mfg Date : 09/20/2009
    CPU Key : 007383D80E5B8E9F814BB9B9F44B6CE3
    1BL Key : DD88AD0C9ED669E7B56794FB68563EFA
    DVD Key : 1B160DFBB484B9CD2F329C4E47A01B20
    CF LDV : 2
    KV type : type2 (hashed - unchecked, master key not available)
    ---------------------------------------------------------------
    xeBuild Finished. Have a nice day.
    ---------------------------------------------------------------
  3. Christianmoel

    Christianmoel Newbie

    Messages:
    8
    Likes Received:
    0
  4. Harben

    Harben Future IT Guy

    Messages:
    1,503
    Likes Received:
    365
    Your default boot option is to boot into FSD. Take out that line in your launch.ini.
  5. Christianmoel

    Christianmoel Newbie

    Messages:
    8
    Likes Received:
    0
    I am aware of that. My problem is that i no longer can access nxe by any means known to me. I have tried changing options in dashlaunch, home + hold RB and so forth. I have also tried to remove my external drive, where fsd and launch.ini is located. Doing the last it simply freezes on the xbox logo. To me it seems like something went wrong in the update. I have tried to revert back to last nand dump, but strangely i can no longer access NXE from there. Note that it plays games just fine, but i am unable to access the NXE menu, along with that, important video and audio settings, which the new update seem to have changed.
    Thanks for the input none the less :)