Is my RGH fried? XD

Discussion in 'Xbox 360 Support Archive' started by AK47xHugley, Mar 31, 2013 with 13 replies and 520 views.

  1. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    So after having my RGH for 2 day I cross-flashed it tried getting that fix and not I think I fried it with my ****y soldering XD
    So before I had started soldering and after I cross-flashed when I would plug it in the CR3 would have a light on and the xbox would make a sound when I plugged it in.
    But now neither of them do anymore So I think I fuked it up XD
    And if that's the case then could it be fixed or should I just buy a new one?
     
  2. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,019
    Likes Received:
    1,925
    Dude like no offense but that was so hard to understand. Are you saying that the red light on the CR3 no longer shows and the xbox wont turn on?
     
  3. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    correct
    sorry I was in a hurry when writing that lol.
     
  4. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,019
    Likes Received:
    1,925
    Most likely you shorted something and blew a MOSFET. Look closes for any solder bits thrown about or accidental connections. After removing any if it still doesnt work you'd have to find the blown MOSFET and replace it which is a b****.
     
    GModz Tuts likes this.
  5. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    well I desoldered the things that were shorting it out....
    so it still don't work so now I'm sol.
    lol oh well time to order a new one XD
     
    oblivioncth likes this.
  6. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    UPDATE so it turns out it is not fried XD
    Just did not notice that the power brick was red so i just unplugged it and pluged it into my cross-flashed RGH and the light on the CR3 is on!!! XD
    Yay there is hope XD now I just need to solder my nand x wires to it very carefully this time.
    Good thing I did not just throw it out.
     
  7. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,019
    Likes Received:
    1,925
    Lol so you used a different power brick or just unplugged and replugged in the same one?
     
  8. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    Same one just unplugged it and plugged it back in XD
     
  9. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,019
    Likes Received:
    1,925
    Did you touch up the solder while the PSU was plugged in?
     
  10. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    Nope.
     
  11. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,019
    Likes Received:
    1,925
    Hmm well the light will turn red if you plug it in and it detects a short, so i dont know why it was red after you cleaned up the soldering.
     
  12. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    Yea it was weird.... oh well all fixed now XD
     
  13. oblivioncth

    oblivioncth Mr. Cloth

    Messages:
    7,019
    Likes Received:
    1,925
    At least it is!
     
  14. AK47xHugley

    AK47xHugley Getting There

    Messages:
    861
    Likes Received:
    126
    Yup now I just gota get my nandx wires soldered XD